Page 1 of 1

Setting up Blender on OS X

Posted: Sat Jun 04, 2016 6:09 pm
by tweakdeveloper
I'm trying to set up Blender on my MacBook, but I'm running the latest OS X, El Capitan. Blender 2.49b runs just fine and the scripts are installed fine, but I can't get them to run. Python is installed, if I run "python" I get Python 2.7 but I can get Python 2.6 by running "python2.6".

When I run Blender, I get the "No installed Python found" error. Is there any way to get Blender to recognize Python 2.6 on modern OS X? Thanks!

Re: Setting up Blender on OS X

Posted: Sat Jun 04, 2016 7:46 pm
by decaff_42
http://ysflightsim.wikia.com/wiki/Insta ... FS_Blender

This is an all-in one download and hopefully will fix your issues. While I had this running prior to upgrading to 10.11 (coming from 10.6 XD) it still runs just fine.

Re: Setting up Blender on OS X

Posted: Sat Jun 04, 2016 8:19 pm
by tweakdeveloper
I installed that one, still no luck. I get an error that says check the console when I try to import a SRF and the console still says "No installed Python found". :(

Re: Setting up Blender on OS X

Posted: Sat Jun 04, 2016 8:33 pm
by decaff_42
Have you installed python 2.5?

Looking through my computer I see that I've got Python 2.5, 2.6, 2.7 and 3.4
10.11 should have 2.7 installed straight from the box.

You may find my video about this helpful, although it is dated.

Re: Setting up Blender on OS X

Posted: Sat Jun 04, 2016 9:12 pm
by tweakdeveloper
Python 2.5 won't install on 10.11, on my MacBook at least. I don't get an error other than that, OS X's installer is terse. :(

BTW, thanks for all your help! I'm really enjoying your CRJ pack and I'm hoping I'll be able to get some use out of your decal pack soon. :)

Re: Setting up Blender on OS X

Posted: Sat Jun 04, 2016 9:17 pm
by decaff_42
tweakdeveloper wrote:Python 2.5 won't install on 10.11
wow. I just tried to install it myself and I get an error with that. I'm glad we can nail that down to OS, rather than something on your computer.

I guess because I had everything installed and then time machined to the new OS, that everything some how carried over? When you were talking about Python 2.6, can you open the IDLE for it?

Have you tried rebooting since installing everything? I don't know if that will work, but perhaps it will initialize something to make things click.

EDIT:
Also what scripts were you trying to use when you got the initial error?

Re: Setting up Blender on OS X

Posted: Sat Jun 04, 2016 9:30 pm
by tweakdeveloper
I can't open the IDLE for 2.6 (can't seem to find it), but I can open the shell with "python2.6". I've rebooted a couple times, trying to get an Ubuntu install working too. Also, I was using the YSFS Blender scripts from SourceForge that are linked to in the getting started guide here.

Re: Setting up Blender on OS X

Posted: Sat Jun 04, 2016 9:32 pm
by decaff_42
perhaps because you don't have the IDLE for 2.6 it isn't installed properly? you might try re-installing it.

Re: Setting up Blender on OS X

Posted: Tue Jun 07, 2016 1:45 am
by dbd000
I installed the ysfs blender scripts just recently. Thanks decaff_42 for the blender tutorials on youtube. Really helpful. Should have watched them ages ago.

Re: Setting up Blender on OS X

Posted: Sat Jun 11, 2016 8:16 pm
by tweakdeveloper
Just tried reinstalling Python 2.6, that one errors out too :(

Re: Setting up Blender on OS X

Posted: Sat Jun 11, 2016 9:36 pm
by decaff_42
hmmm... This is quite perplexing. Have you tried to install other python scripts besides the YSFlight scripts? This might help determine if it is a python issue or improperly installed script or something else.

Re: Setting up Blender on OS X

Posted: Sun Jun 12, 2016 12:05 pm
by tweakdeveloper
I haven't tried to install any other scripts, but I believe the YSFS Blender scripts are installed correctly since the Import/Export options show up on the menu.

Side note: I'd be perfectly happy to use the new scripts with Blender 2.7, but they're missing an import SRF/DNM function at the moment, which is troubling.

Re: Setting up Blender on OS X

Posted: Fri Sep 16, 2016 10:08 pm
by u2fly
tweakdeveloper wrote:I haven't tried to install any other scripts, but I believe the YSFS Blender scripts are installed correctly since the Import/Export options show up on the menu.

Side note: I'd be perfectly happy to use the new scripts with Blender 2.7, but they're missing an import SRF/DNM function at the moment, which is troubling.
Try read next topic, maybe it would be helpfull for solve this problem
>>> http://forums.x-plane.org/index.php?/fo ... nt-1020308