YS version 20110207 runs smooth as glass, but newest version is only 1fps?

Questions, comments, concerns, & fixes
User avatar
megaprime13
Contributor
Contributor
Posts: 289
Joined: Tue Mar 04, 2014 12:00 am
Favorite Aircraft: 737
Location: Lead. You should stay on my wing.
Has thanked: 33 times
Been thanked: 36 times

YS version 20110207 runs smooth as glass, but newest version is only 1fps?

Post by megaprime13 » Fri Sep 18, 2015 3:34 pm

I decided to post in misc. because i couldnt think of any better place. mmmkay?

Mac OSX 10.6.8 32bit
I came back to the community earlier this year, and i promptly left because of a personal lack of interest in the sim.

I'm back now, and i would like to fly with old friends on the forum server: play.ysflight.org (in case anyone forgot).

And i downloaded the latest version of ysflight from the official ys website, opened it up and....

WOW! it looks really nicely upgraded! new pics for the home screen and everything! :mrgreen: :mrgreen:

I then noticed the increased lag on the home screen and much to my disappointment, it was also in game. i'm talking 1fps. i used to get over 150fps running the older version 20110207.

So i turned down the settings to the lowest, and still this lag persists! So i come seeking advice so i can get back into this wonderful sim and the mirrored community, without being postponed by needing to spend a butt load of money on a computer that i dont have money for.

User avatar
Varren
Banned
Banned
Posts: 453
Joined: Wed Mar 06, 2013 6:31 pm
Favorite Aircraft: Anything with wings.
Has thanked: 19 times
Been thanked: 45 times

Re: YS version 20110207 runs smooth as glass, but newest version is only 1fps?

Post by Varren » Fri Sep 18, 2015 5:38 pm

If you're not already, use the direct x version (ysflight32_d3d9.exe)

If that fails then I'd suggest having a look at updating your drivers.
Image

User avatar
megaprime13
Contributor
Contributor
Posts: 289
Joined: Tue Mar 04, 2014 12:00 am
Favorite Aircraft: 737
Location: Lead. You should stay on my wing.
Has thanked: 33 times
Been thanked: 36 times

Re: YS version 20110207 runs smooth as glass, but newest version is only 1fps?

Post by megaprime13 » Fri Sep 18, 2015 7:54 pm

Varren wrote:If you're not already, use the direct x version (ysflight32_d3d9.exe)

If that fails then I'd suggest having a look at updating your drivers.
I am running Macintosh OSX as i said in my original post, and Apple has not updated my machine for a few years now.
Copperhead: "I could care less about politics anyways"
Sentinel182 wrote: at the moment im this many years
*middle finger*

User avatar
Nodoka Hanamura
Veteran
Veteran
Posts: 923
Joined: Thu Apr 07, 2011 8:01 pm
Favorite Aircraft: Su-24, Mig-29, Su-27, F-18, F-15, ADF-01, Icon A5
Has thanked: 513 times
Been thanked: 266 times

Re: YS version 20110207 runs smooth as glass, but newest version is only 1fps?

Post by Nodoka Hanamura » Fri Sep 18, 2015 11:33 pm

I don't see how YSFlight would run so poorly on a Mac. Could you try running YSFlight in a VM and see if it runs well then? Maybe it could be some kind of issue with OpenGL on your machine.
█████████████████████████████████████████████████████████████████████
Image

User avatar
megaprime13
Contributor
Contributor
Posts: 289
Joined: Tue Mar 04, 2014 12:00 am
Favorite Aircraft: 737
Location: Lead. You should stay on my wing.
Has thanked: 33 times
Been thanked: 36 times

Re: YS version 20110207 runs smooth as glass, but newest version is only 1fps?

Post by megaprime13 » Sat Sep 19, 2015 12:14 am

Mahora-27 wrote:Could you try running YSFlight in a VM and see if it runs well then? Maybe it could be some kind of issue with OpenGL on your machine.
just tried with winehelper, it didnt even load.
Copperhead: "I could care less about politics anyways"
Sentinel182 wrote: at the moment im this many years
*middle finger*

NightRaven
Senior Veteran
Senior Veteran
Posts: 1844
Joined: Tue Feb 07, 2012 10:00 am
Favorite Aircraft: .
OS: windoze 10 64-bit
Has thanked: 547 times
Been thanked: 608 times

Re: YS version 20110207 runs smooth as glass, but newest version is only 1fps?

Post by NightRaven » Sat Sep 19, 2015 2:23 am

I'm assuming you have already deleted 20110207 from your system, so try redownloading it and see if it still works at 150fps, as you claim it did. https://ysflight.org/download/

Also see if other games that are much more demanding work smoothly on your computer.

Other than that I don't know, maybe try redownloading the latest update for your Mac and reinstalling it or try and clean up your HDD?

I don't see that this is a problem with YS itself; the only real change is the addition of new variables and the OpenGL2 version, which has been "optimised" anyway (according to Soji).

User avatar
megaprime13
Contributor
Contributor
Posts: 289
Joined: Tue Mar 04, 2014 12:00 am
Favorite Aircraft: 737
Location: Lead. You should stay on my wing.
Has thanked: 33 times
Been thanked: 36 times

Re: YS version 20110207 runs smooth as glass, but newest version is only 1fps?

Post by megaprime13 » Sat Sep 19, 2015 3:15 am

NightRaven wrote:I'm assuming you have already deleted 20110207 from your system, so try redownloading it and see if it still works at 150fps, as you claim it did. https://ysflight.org/download/

Also see if other games that are much more demanding work smoothly on your computer.

Other than that I don't know, maybe try redownloading the latest update for your Mac and reinstalling it or try and clean up your HDD?

I don't see that this is a problem with YS itself; the only real change is the addition of new variables and the OpenGL2 version, which has been "optimised" anyway (according to Soji).
1. nope. still have it because muh mods.
2. TF2 used to run about 25/30 fps until they made it incompatible with my machine.
3.i dont know if my computer is a real fan of opengl, but i assume it isnt ys fault.
Copperhead: "I could care less about politics anyways"
Sentinel182 wrote: at the moment im this many years
*middle finger*

NightRaven
Senior Veteran
Senior Veteran
Posts: 1844
Joined: Tue Feb 07, 2012 10:00 am
Favorite Aircraft: .
OS: windoze 10 64-bit
Has thanked: 547 times
Been thanked: 608 times

Re: YS version 20110207 runs smooth as glass, but newest version is only 1fps?

Post by NightRaven » Sat Sep 19, 2015 3:22 am

Try doing a benchmark (if there are for Macs).

Does your existing 2011 install continue to run at 150 fps?
Also, which type of YS are you using? The OpenGL 1 version or OpenGL 2 version? Does the low framerate affect both or just one?

User avatar
megaprime13
Contributor
Contributor
Posts: 289
Joined: Tue Mar 04, 2014 12:00 am
Favorite Aircraft: 737
Location: Lead. You should stay on my wing.
Has thanked: 33 times
Been thanked: 36 times

Re: YS version 20110207 runs smooth as glass, but newest version is only 1fps?

Post by megaprime13 » Sat Sep 19, 2015 3:34 pm

NightRaven wrote:Try doing a benchmark (if there are for Macs).

Does your existing 2011 install continue to run at 150 fps?
Also, which type of YS are you using? The OpenGL 1 version or OpenGL 2 version? Does the low framerate affect both or just one?
No idea what you are talking about with a benchmark.

2. yes it still runs at 150fps
3. i dont know which opengl version, therefore i cant answer that question mentioning framerate
Copperhead: "I could care less about politics anyways"
Sentinel182 wrote: at the moment im this many years
*middle finger*

User avatar
Neocon
First Class Membership
First Class Membership
Posts: 3843
Joined: Wed Oct 19, 2011 5:01 am
Favorite Aircraft: Baron 58
Location: Tennessee
OS: Win 10
Has thanked: 1611 times
Been thanked: 1727 times
Contact:

Re: YS version 20110207 runs smooth as glass, but newest version is only 1fps?

Post by Neocon » Sat Sep 19, 2015 5:31 pm

Did you try copy and pasting the new .exe (with different names) into your 2011 install? Then you can try the new .exe with the old ground objects, scenery, aircraft, etc.

User avatar
megaprime13
Contributor
Contributor
Posts: 289
Joined: Tue Mar 04, 2014 12:00 am
Favorite Aircraft: 737
Location: Lead. You should stay on my wing.
Has thanked: 33 times
Been thanked: 36 times

Re: YS version 20110207 runs smooth as glass, but newest version is only 1fps?

Post by megaprime13 » Sat Sep 19, 2015 5:45 pm

Patrick31337 wrote:Did you try copy and pasting the new .exe (with different names) into your 2011 install? Then you can try the new .exe with the old ground objects, scenery, aircraft, etc.
i dont know why, but everyone thinks im running windows

I AM RUNNING MAC OSX 10.6.8 NOT WINDOWS!!! I AM NOT USING .EXE FILES

i can still try to copy paste the files, but i dont think they will be compatible with the servers, will they?
Copperhead: "I could care less about politics anyways"
Sentinel182 wrote: at the moment im this many years
*middle finger*

User avatar
Neocon
First Class Membership
First Class Membership
Posts: 3843
Joined: Wed Oct 19, 2011 5:01 am
Favorite Aircraft: Baron 58
Location: Tennessee
OS: Win 10
Has thanked: 1611 times
Been thanked: 1727 times
Contact:

Re: YS version 20110207 runs smooth as glass, but newest version is only 1fps?

Post by Neocon » Sat Sep 19, 2015 7:34 pm

Did you try updating to a PC with Windows? :lol:

User avatar
megaprime13
Contributor
Contributor
Posts: 289
Joined: Tue Mar 04, 2014 12:00 am
Favorite Aircraft: 737
Location: Lead. You should stay on my wing.
Has thanked: 33 times
Been thanked: 36 times

Re: YS version 20110207 runs smooth as glass, but newest version is only 1fps?

Post by megaprime13 » Sat Sep 19, 2015 9:16 pm

Patrick31337 wrote:Did you try updating to a PC with Windows? :lol:
yeah i did, and then i remembered why i hate windows and my lack of funds for a new computer.


replacing the files did nothing. i dont know what the next step should be....
Copperhead: "I could care less about politics anyways"
Sentinel182 wrote: at the moment im this many years
*middle finger*

User avatar
Flake
Core Staff
Core Staff
Posts: 4354
Joined: Thu Feb 10, 2011 8:47 pm
Favorite Aircraft: Boeing F/A-18A
Location: Australia
OS: Windows 10 (x64)
Has thanked: 836 times
Been thanked: 1238 times
Contact:

Re: YS version 20110207 runs smooth as glass, but newest version is only 1fps?

Post by Flake » Sat Sep 19, 2015 10:29 pm

Lol guys.

Sounds like your graphics card is either ancient or in dire need of a driver update - do macs even have driver updates?

Apple make great phones, media players etc. NOT good computers.

Do yourself a favour and bootcamp windows and leave OSX behind. Not the advice you want to hear, but honestly it's the best you will get.
I am an accountant working full-time (and some). I'm not here as often as I would like to be. Send a message if you need me. There are a few people in the community who can get in contact with me urgently if you need - don't be afraid to ask. I just don't check here as frequently as I used to. Sorry!

User avatar
megaprime13
Contributor
Contributor
Posts: 289
Joined: Tue Mar 04, 2014 12:00 am
Favorite Aircraft: 737
Location: Lead. You should stay on my wing.
Has thanked: 33 times
Been thanked: 36 times

Re: YS version 20110207 runs smooth as glass, but newest version is only 1fps?

Post by megaprime13 » Sat Sep 19, 2015 10:52 pm

OfficerFlake wrote:Lol guys.

Sounds like your graphics card is either ancient or in dire need of a driver update - do macs even have driver updates?

Apple make great phones, media players etc. NOT good computers.

Do yourself a favour and bootcamp windows and leave OSX behind. Not the advice you want to hear, but honestly it's the best you will get.
apple use to update the drivers, and then they stopped.

if you want to send me money to my paypal account for a new computer please do for the ysf fund! ;)
Copperhead: "I could care less about politics anyways"
Sentinel182 wrote: at the moment im this many years
*middle finger*

NightRaven
Senior Veteran
Senior Veteran
Posts: 1844
Joined: Tue Feb 07, 2012 10:00 am
Favorite Aircraft: .
OS: windoze 10 64-bit
Has thanked: 547 times
Been thanked: 608 times

Re: YS version 20110207 runs smooth as glass, but newest version is only 1fps?

Post by NightRaven » Sun Sep 20, 2015 7:31 am

megaprime13 wrote:
NightRaven wrote:Try doing a benchmark (if there are for Macs).

Does your existing 2011 install continue to run at 150 fps?
Also, which type of YS are you using? The OpenGL 1 version or OpenGL 2 version? Does the low framerate affect both or just one?
No idea what you are talking about with a benchmark.
You could have googled it..? :roll:
It's essentially a way of finding out your Mac's performance relative to other computers based on a set criteria. If it performs poorly then... yeah, you might need a new comp.
megaprime13 wrote:3. i dont know which opengl version, therefore i cant answer that question mentioning framerate
I just downloaded the OSX version of YS, and the only program I saw in the zip that looked anything like YS was in /Contents/MacOS/ysflight_gl2 (or something like that). That means you're pretty much stuck with OpenGL 2.

I can't suggest anything much, given the lack of resources to get a new comp, apart from cleaning up your system.

Also, I noticed in the OP you are using a 32-bit version of OSX, but in the readme it says you need a 64-bit version as part of the minimum requirements, so that could be the issue. I don't see how this can be resolved apart from getting a new computer or doing something radical to your Mac (like reinstalling a new 64-bit version of OSX if it is available for download and hopefully not bricking it).

User avatar
decaff_42
Staff
Staff
Posts: 3562
Joined: Sat Oct 29, 2011 7:23 pm
Favorite Aircraft: SR-71 Blackbird
Location: Eastern United States
OS: Mac OSX
Has thanked: 625 times
Been thanked: 1363 times
Contact:

Re: YS version 20110207 runs smooth as glass, but newest version is only 1fps?

Post by decaff_42 » Sun Sep 20, 2015 7:40 pm

My 2010 macbook pro runs YSF between 8 and 99 fps. never seen 150 fps...
Check out my website YSDecaff for all my tutorials and addon releases.
Visit by Bitbucket page for Python codes: https://bitbucket.org/decaff42/

Server Flight Log
Addon Database Submit Addon To Database

User avatar
megaprime13
Contributor
Contributor
Posts: 289
Joined: Tue Mar 04, 2014 12:00 am
Favorite Aircraft: 737
Location: Lead. You should stay on my wing.
Has thanked: 33 times
Been thanked: 36 times

Re: YS version 20110207 runs smooth as glass, but newest version is only 1fps?

Post by megaprime13 » Sun Sep 20, 2015 10:29 pm

decaff_42 wrote:My 2010 macbook pro runs YSF between 8 and 99 fps. never seen 150 fps...
well i have an 05 imac but i bought it used all those years ago and when i replaced the hard drive some parts looked different than the tutorials online. it may be possible someone modified it?
Copperhead: "I could care less about politics anyways"
Sentinel182 wrote: at the moment im this many years
*middle finger*

User avatar
Dragon_Mech
Veteran
Veteran
Posts: 571
Joined: Wed Jul 15, 2015 12:18 pm
Favorite Aircraft: F-14, F-15D&E, SR-71, King Air 200, B737
Location: Mansfield, Mo. USA
OS: Windows 7 Ultimate
Has thanked: 94 times
Been thanked: 127 times

Re: YS version 20110207 runs smooth as glass, but newest version is only 1fps?

Post by Dragon_Mech » Mon Sep 21, 2015 5:02 am

i've used both the GNU linux and the windows versions of the 2015 version of YSFlight. with just the stock maps and aircraft i rarely fall below 50 fps with 64fps being the maximum frame rate using both the opengl 1.x and directx versions. and i'm using and nvidia quadro nvs 290 with an amd athlon 64 @ 2.4GHz.
Owner, Dragonic Machine Industries
Image

NightRaven
Senior Veteran
Senior Veteran
Posts: 1844
Joined: Tue Feb 07, 2012 10:00 am
Favorite Aircraft: .
OS: windoze 10 64-bit
Has thanked: 547 times
Been thanked: 608 times

Re: YS version 20110207 runs smooth as glass, but newest version is only 1fps?

Post by NightRaven » Tue Sep 22, 2015 1:57 am

megaprime13 wrote:Mac OSX 10.6.8 32bit
In ereadme.txt:
Image
From DigitalTrends:
Through hardware emulation, it’s possible to run 32-bit software and operating systems on a machine with a 64-bit processor. The opposite isn’t true however, in that 32-bit processors cannot run software designed with 64-bit architecture in mind.
I suppose that would be your issue (if you hadn't seen my edit in my previous post).

Post Reply

Who is online

Users browsing this forum: No registered users and 2 guests