Installing older/newer versions on Mac

Questions, comments, concerns, & fixes
Post Reply
Mincalo
Newbie
Newbie
Posts: 1
Joined: Sat Jul 02, 2022 7:00 pm
Favorite Aircraft: F-104 Starfighter
OS: Mac
Been thanked: 2 times

Installing older/newer versions on Mac

Post by Mincalo » Sun Jul 03, 2022 4:05 pm

There seems to be and issue on Mac where if you have a newer version of the game installed any older versions simply won't work. Every time you launch will give the message "YSFlight has quit unexpectedly." however there is a fix which is completely deleting the newer version which is a simple process.

1. this step is optional but I recommend that you screenshot or in some way save your keybinds and your addons.

2. next delete the ysflight folder (to find this easily just right click your ysflight shortcut and select options>show in finder)

3. go to /Users/username/Library/Application Support and delete YSFLIGHT.COM and do the same with /Users/username/Documents/YSFLIGHT.COM

4. download and install the older version of your choice and it should run just fine. at this point you can re-add your addons and keybinds

User avatar
waspe414
Staff
Staff
Posts: 1532
Joined: Thu Feb 10, 2011 9:35 pm
Favorite Aircraft: Kiowa, Mitten, Hornet
Location: Canada
Has thanked: 148 times
Been thanked: 488 times
Contact:

Re: Installing older/newer versions on Mac

Post by waspe414 » Sun Jul 03, 2022 4:50 pm

Some versions of Mac don't support the 32bit 2015 at all, so if the above still doesn't work, you can download 20170517 test version, which is 64 bit and compatible with 2015 servers
Actual UltraViolet
Image Image
Image
I stole your turnip. Now you must come and defend your honour. ~ Hank Green

Post Reply

Who is online

Users browsing this forum: No registered users and 0 guests